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1. Introduction

This software is designed for stereonet-based rock mass characterization and kinematic analysis of
rock slopes. It allows users to import joint data, visualize discontinuities, define slope geometries,
and perform kinematic failure analyses including planar, wedge, and toppling modes.

2. Main Window
The Main Window is the primary workspace for importing joint data, visualizing stereonet plots, and
preparing data for kinematic analysis.

2.1. File Menu

File » Open B

Opens an existing project file. The software supports files with the .pass extension.

File » New File

Creates a new project file. The software prompts the user to save the current workspace
before clearing all data and opening a clean window.

File » Import Joint Specifications []}:—
Imports joint data from a CSV file.
e The software automatically matches CSV column headers with internal table fields
in Compass 3 table including Type, Dip, Unadj. Dip/Dir, Color, Symbol, and Size.
e The number of rows or columns is unrestricted.
e [Ifarequired column is not found, default values (e.g., zero, black color, small size)
are applied automatically.
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2 46b2c60a¢ Locality1 0821ab0d 610587.4 5567609 50.25028 -121.449 10U 0 1 -1 Bedding 42.64587784 2634017029 193.4017 15.60462 Unitl  ThuNov1

3 46b2c60at Locality1 eala3ed6 610587.4 5567609 50.25028 -121.449 10U 0 1 -1 Bedding 86.80161285 101.9639053 11.96391 15.60462 Unitl  ThuNov1
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File » Save Current State %
Saves the current project.
o Ifthefile has been previously saved, it overwrites the existing file.
e Otherwise, the user is prompted to select a name and directory.
¢ Ifthe Compass 3 logo does not appear on the file, right-click on the saved file,
select Properties, and set the file to open with Compass 3. This step only needs to
be done once. After that, your computer will recognize all Compass 3 files
automatically in the future.

AS

File » Save Current State As
Prompts the user to select a directory and filename to save the project.

File » Cancel Changes and Close %
Discards all unsaved changes and closes the window after user confirmation.

1 Unsaved Changes X

. 'Document 1' has unsaved changes. Do you want to save
7!; before closing?

Yes No Cancel




File » Close Window ®
Closes the active window after warning and user approval.

. Table Menu
This menu is located below the table.
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Declination Angle Declination Angle (%): ? 0

Defines the declination angle (the difference between true north and magnetic north).
Enter the value in the text box based on the project location. If you do not know the value,
click the question mark icon. This will direct you to a website where you can find the
declination angle by locating your project area and left-clicking on the map. The
declination angle will be displayed. Copy and paste the value into the text box. The
maximum allowed input is two digits.
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Update Dip/Dir |Peate Dip/Dir

Adjusts the dip direction based on the entered declination angle and updates the values in
the table. Two red triangles on the stereonet indicate the true north and magnetic north
directions.
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Add Row

The table initially contains 100 rows. Clicking Add Row adds an additional row to the table.

Delete Row

Deletes the selected row from the table and automatically renumbers the remaining rows.

2.3. Edit Menu

Edit > Copy @

Copies joint specifications from the table. The copied data can be pasted into Excel.

Edit » Paste &

Pastes joint specifications from Excel into the software table.
Required columns:

e JointType

e Dip

e Unadjusted Dip Direction
- Only copy the numbers not headers.

0\

Edit > Reset View \-)
Resets the stereonet scale and position to its default state.



2.4. Input Menu

/-
AR T
Input » Load Main Planes
Loads previously defined main planes from the Kinematic Analysis Window into the Main
Window.

Main discontinuities must be defined and saved in the Kinematic Analysis Window before
loading.

\ / _——

/ \ Name Dip Dip/Dir Color  Symbol
/ Plane 1 58.8° 309.9° -\ Circle
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. A Plane 4 3.2 8.3 )| Triangle
s
180°
2.5. Output Menu
Output > Draw PolesC>
Plots joint poles on the stereonet.
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Output > Draw Contours :
Generates contour plots of joint density on the stereonet.

x Pole Density

.|

High 4005
80%

60%

40%
l 20%
0%

270° W 00°

180°

Output > Draw Planes @
Draws great circles for all joint sets on the stereonet.




(FERY
Output > Draw Main Loaded Planes 2
Draws great circles for the main rock mass discontinuities loaded using Input > Load Main

Planes.

Main Planes

Name Dip Dip/Dir Color  Symbol

Plane1 |[58.8°| 3€9.9° Circle

Plane2 |5@.8° Square

Plane 3 |61.4° Diamond

Plane4 |53.2° 8.3° Triangle

2.6. Analysis Menu

=1

Opens the Kinematic Analysis Window.

Analysis > Kinematic Analysis

Analysis 2 Limit Equilibrium Analysis A
Not available in this version. It is under development.

Analysis > Photogrammetry Menu @
Not available in this version. It is under development.

Kinematic Analysis Window =
The Kinematic Analysis Window is used for slope definition, 3D visualization, and
kinematic failure evaluation.

3.1. File Menu

File » Save
Saves the current state of the Kinematic Analysis Window.
Note: Saved data persists only while the software remains open.



File » Cancel [%

Cancels all changes and closes the window after user confirmation.

File » Close Window

Closes the window after warning and user approval.

3.2. Edit Menu

Edit > Delete Selected Plane @
Removes a selected plane or cross section from the tables and views.

O

3.3. Input Menu

Input > Load Stereonet

®

Loads joint poles and contours from the Main Window into the stereonet.

Input > Load Ground Surface

-
s

Imports ground surface data from:

e CSVfile (inx,y, zformat with no header and notes)

@ AutoSave (. OH\'

File Home

M14

A
610314.4
610314.4
610314.4
610314.4
610312.4
610314.4

BwW N -

[ V]

Insert

B
5568194
5568192
5568190
5568188
5568184
5568186

Page Layout

Jx
C
236.88
236.831
236.736
236.504
236.199
236.079

Site 12 « Saved to this PC v

Help

£ Search

BLUEBEAM



ELE.

Min: 5568067.6
Max: 5568205.6

N

Input > Load Photogrammetry Model
Imports photogrammetry model in and OBJ format

Min: 225.0
MAI:F'IS.Z
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ELE.

Min: 207.4
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o
Input > Load New Features

Adds linear features to the ground surface using a CSV file containing x and y coordinates
only. The software automatically offsets the feature onto the surface. Make sure you have

enough points to form a good feature.
@ AutoSave H ¥ (3 (3 changes f}flackChanges (tegag)v ¥ Portal » Savedtot.. v

File  Home Insert Pagelayout Formulas Data Review View Automate Help BLUEBEAM

Al v i Jx | 610365.463
| A B | € | o | E | F | 6 | ® | W | 3
1 | 610365.5_| 5568175

2 [ 610365.4 5568175
3 | 6103654 5568175
4 | 610365.3 5568175
5 | 6103653 5568174

Min: 225.0
3792

Input > Add Boundary g‘
Extrudes the ground surface to create a transparent 3D volume or slice.

11



ELE.
Min: 225.0

Input > Delete Boundary Q
Removes the extruded boundary and displays only the ground surface.

3.4. Output Menu

Output > Select Main Planes®
Allows manual selection of planes directly on the stereonet.
e Clicking adds a pole, great circle, and corresponding 3D plane.
e Plane location and orientation can be edited from the table (dip, dip direction, x,

Y, Z).

12



Specifications of Selected Cross Sections

Name Dip Dip/Dir
Plane 1

Specifications of Selected Main Planes

Color  Symbol  Visibility X
Cirde | |510‘3mz E|

493 E 484 E| =)

Y z
5,568,128.96 @| 28883 E|

Specifications of Selected Cross Sections Specifications of Selected Main Planes

Pole Density

Section #  Friction Angle (%) Slope Dip (%) Slope Dip/Dir (%) Lateral Limit (?) Vertical Dis.  Horizontal Dis. 3D Length Name  Dip Dip/Dir  Color  Symbol  Visibility X v z

Plane 1 |75 E 1369 E |l il O |[ze El 063 E 22507 E
| Plane3 [a] Diamond

736 E 2027 | | O |haes E| 063 E 22507 @
Planed |57g E{ 20 @ W (e | O |[2e @| 083 E] 22607 E|
e 275 E 19 @ | i 1264 @ 6 E\ 22507 E|
Plane 5 Cross
| 747 E! 2910 E | | 1620 @l 063 @ 22507 El

S5
Output > Detect Main Planes -
Automatically detects dominant discontinuity sets.

e User selects the number of planes (1-6, default = 4).

e Detected planes can be edited or deleted.

[#j Plane Detection Settings

Maximum number of planes to detect:

OK || Cancel

13
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Specifications of Selected Cross Sections Specifications of Selected Main Planes

Name  Dip Dip/Dir  Color Symbol  Visibility X Y
Plane 1 |55 \E] 3085 E] W o aasﬁ‘zﬁl 53

A Z;zqs;aa' 15l

Square

Rk EO-L@ ELL‘E] L1285 | EI (e | El

a3
-
=
3

[610377.12] El

3]

Plane 3 'mg ﬁ@ | [0
Plane 4 [ o35 ‘E = jl% ]

Triangle

3]

foozrrz) (8] sseareese) (3] fseas | 3]

Pole Density
High 1000,

E 90°

Output > Main Planes Intersections @
Displays intersections of main discontinuities as color-coded crosses on the stereonet.

Specifications of Selected Main Planes

Name Dip Dip/Dir Color  Symbol  Visibility X Y. 74
Plane 1 Z I Z Circle Z Z Z
(582 |15 (3009 |15 | I [610377.12] [5H| [5.568,128.96 | (7| [288:83 | [T
Plane 2 [0 4] | A | Square N LA A
(508 |13 [4a6 |15 | W [610377.12] [31| [5.568,128.96 | r&| (28883 | [+
Plane 3 [, ||A| 5775 | Al Diamond A A 1Al
614 1[5 2175 ]3] [ | (61037712] ]| (556812896 | (3] (28883 | [5;
Plane 4 |A| A Triangle A A N
532 |15 (83 |{51 | M [610377.12] 51| [5.568.128.96 | 5| (28883 | [
0°
270° W E 90°

1ene
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Output > Cross Section
Creates a cross section by selecting two points on the ground surface.

£

Make sure the first point is higher than the second.

The table displays:

Specifications of Selected Cross Sections

Average slope angle

Dip direction of the slope

Vertical distance between two points
Horizontal distance between two points
3D length between two points

Friction angle

Lateral limits

Section # Friction Angle (°) Slope Dip (°) Slope Dip/Dir (°) Lateral Limit (°) Vertical Dis. Horizontal Dis. 3D Length

Color

Min: 5568067.6
Max: 5568205.6

Output > Draw Rock Slopes @
Draws great circles of cross sections on the stereonet.

15

#1 (a] 54.1° 35° T [a] |135.69 9847 167.65
5 o |5 O
# N 55.6° 16° la] [131.69 90.80 159.96 |:|
v h
#3 N 53.6° 350° [a] [12563 9375 156.76 ]
v v
<
ELE.
Min: 225.0
Mmrm




Specifications of Selected Cross Sections

Specifications of Selected Main Planes

Section # Friction Angle (°) Slope Dip () Slope Dip/Dir (°) Lateral Limit (%) Vertical Dis.  Horizontal Dis. 3Dlength  Color Name  Dip Dip/Dir  Color  Symbol Visibility X ¥ z
#1 ‘EE 541° 35t [I’E 13569 98.47 167.65 I Plane 1 |55 E] 9 E | o 51037712 El 556812896 E| ETH
2 7 E 556" 16 E 13169 9080 15996 [ Plane 2 5o o E e @ ] Square 1037712 @I 556812696 @| ]
#3 ‘EE 536° 350° 12563 9375 156.76 [ Plane 3 [o1 E 175 E ] Diamond 61037712 E| 556812896 E| 2881
> [ | Pene4 532 E 83 E | [T 610377.12 E| 5568,128.96 EI 288

0

180°
i L2
Wi S568567.6
M 5568205.6
Specifications of Selected Cross Sections Specifications of Selected Main Planes
Section # Friction Angle () Slope Dip (?)  Slope Dip/Dir (9) Lateral Limit (%) Vertical Dis. Horizontal Dis. 3D Length || Name Dip Dip/Dir  Color Symbol  Visibility X z
1 [a] 743° 333° - |[&] 2870 808 2982 Plane 1 [a] [a] Circle [a] [a] 4]
4 [ |} 709 | (1369 1% | O | [2es 2| [0s3 1| (22507 | &
=2 NENGES 356 NINEEE 1341 3445 Plane 3 [a] ] Diamond Al a] [a]
= o 736 |14 [2027 7% | 1264 2| [oe 4| 22507 |
3 SIS 326" A [3120 963 3265 Plane 4 [a] 4] Triangle &[T [a] &l
w0 |5 5 519 i 20 |15 [ M O | [2es | [os2 Ivl| 2897 1 51
< Plane 2 a| [a] Square [a]] - a] A
s A e | 1264 2 (16 2| 22507 | &
Plane 5 [5,5|[4] 5614 1[4] Cross = [a]l a] 1 [A]
727 |& 2010 7% | 1620 | 083 S| (22507 ] 5

Output > Kinematic Projection Boundaries
Adds friction cones, lateral limits, daylight envelopes, and fictitious great circles after user
confirmation.

16




[#i Kinematic Projection Boundar... — O X

Daylight

Friction Cone

Lateral Limit Lines
Fictitious Great Circles

| SelectAll | | DeselectAll |

[ ok || Cancel |

[§

Specifications of Selected Cross Sections Specifications of Selected Main Planes.

Section # Friction Angle (°) Slope Dip (°)  Slope Dip/Dir (°) Lateral Limit (°) Vertical Dis. Horizontal Dis. 3D Length Color Name Dip Dip/Dir Color  Symbol Visibility X ¥ z

=2 |E |ss_3- |1s- | E ||3|.7s |9zos ||so.73 | O Plane 1 |;'sTs EE 3009 1 5 W [ 037z E| (556812856 E| [

- 2 J || Plane2 |15913 \5 446 5 W [ 610377.12] E| 5,568,128.96 E| [288:
Pere3 12 4] [ors 4 | W [P e1037712] E| [5568,12896 |§| [288:
Pere 550 11 [os 4| W [ 61037712 E| [5.568,128.96 @| (288

Output > Kinematic Projection .‘

Generates kinematic failure envelopes based on selected failure modes:
e Planar
e Wedge
e Toppling
[Z§ Kinematic Analysis Options - (m] X i
Plane Failure

Wedge Failure
Toppling Failure

| SelectAll | | DeselectAl |

[ ok || cancel |
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Specifications of Selected Cross Sections Specifications of Selected Main Planes

Section # Friction Angle (°) Slope Dip (9 Slope Dip/Dir () Lateral Limit () Vertical Dis. Horizontal Dis. 3D Length  Color Name  Dip Dip/Dir  Color Symbol Visibility X v z

#2 |@E Iss.3' |15' |ME |131.76 |92.06 ||60473 IEV Plane 1 £% 3009 B | o @-M<%| 556612696 E| 22

< — = 2 Plane 2 508 % x5 E B = 610377.12. %| 556812896 E| [288.
Plene3 514 E 2175 E | e 610377.12 E| 556812896 E| 288
Plane 4 535 E 83 B W [Teree 51p,377.1g4@| 556812896 E| 288,

180°

Specifications of Selected Cross Sections

Section # Friction Angle (°) Slope Dip (°)  Slope Dip/Dir (°) Lateral Limit (°) Vertical Dis. Horizontal Dis. 3D Length

#1 A 7437 333° . | A 28.70 8.08 29.82
= 20° (5]
v v
#2 |A| 67.3° 358° Al [3173 1341 3445
v v
#3 a00 | A s 326° Z 31.20 9.63 3265
v v 0°

E 90°

180°

Output > Reset the Window
Resets either the stereonet or 3D view after user approval.

18
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Clear Window Warning

9 Warning: This will reset and clear the window. Are you sure
you want to continue?

Yes No

[#i Clear Options X

Select the Win:

[] Reset the Stereonet Win

[C] Reset the 3D View Win

| oK | | Cancel

4. Control Panel
The Control Panel allows users to toggle visibility of all features using checkboxes.
Each element (planes, surfaces, features, boundaries) can be turned on or off
independently.

File Edit Input Output

BRAOCA~4IOODSOEOO0 G

Ce 1 P: Specifications of Selected Cross Sections Specifications of Selected Main Planes
~ | section# Friction Angle (?) Slope Dip (%) Slope Dip/Dir (?) Lateral Limit (°) Vertical Dis.  Horizontal Dis. 3DLength  Color Name Dip Dip/Dir  Color Symbol Visibility X ¥ z
Stereonet Features e . e A i
o *1 | E |soo |37 l 20 E ||42A9 |1|9.6| ||ar>04 ‘ = Plane 1 | 55q Ei e @ B o 0371 @ 56812655 El =
Joint Poles = = =
Contour Map < e Y E 6 E W [ 610377.12 E| 556812896 E| 288
[] Cross Section Poles -
Slope Great Circles Plane 3 514 E 2175 E i 610377.12 E| 556812696 E| 2881
3D View Features Plane 4 E E Triangle @ E =
e B a 532 83 [ | 610377.12 5,566,128.96 288
(] Photogrammetry Model Maxi379.2
Ground Surface Mesh
Coordinate Axes
Model Boundary
o

Poles and Great Circles
Plane 1 Pole

Plane 1 Great Circle
Plane 2 Pole

Plane 2 Great Circle
Plane 3 Pole

Plane 3 Great Circle
Plane 4 Pole

Plane 4 Great Circle

Pole D
High

Added Planes
Plane 1
Plane 2
Plane 3
Plane 4

Low

Loaded Features and Envelopes
Portal

Daylight Envelopes o
Friction Cones _ S a—
Lateral Limit Lines

Fictitious Great Circles
Plane Failure Envelopes
Wedge Failure Envelopes

Toppling Failure Envelops
Cross Sections

Cross Section #1

5. Notes and Limitations

e Limit Equilibrium and Photogrammetry modules are not available in the current
version.
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